// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\\((0_ASW|10_BSW)\\)([A-Za-z0-9]+)").unwrap();
let string = "C:\\MyPath\\0_ASW\\Mod2000
C:\\MyPath\\0_ASW\\Mod2005\\SubDir
C:\\MyPath\\10_BSW\\ModA\\SubDir
C:\\MyPath\\10_BSW\\ModB
C:\\MyPath\\10_BSW\\ModC\\
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}