use strict;
my $str = 'C:\\MyPath\\0_ASW\\Mod2000
C:\\MyPath\\0_ASW\\Mod2005\\SubDir
C:\\MyPath\\10_BSW\\ModA\\SubDir
C:\\MyPath\\10_BSW\\ModB
C:\\MyPath\\10_BSW\\ModC\\
';
my $regex = qr/\\((0_ASW|10_BSW)\\)([A-Za-z0-9]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}