#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\d+\/\d+(?:\h\w+)+)\h(?:\w+\.)?([a-zA-Z]+)(?:\h(\d+))?$"
Local $sString = "9/91 a1 2a cx.papaya 94000" & @CRLF & _
"9/92 b2 3a x44b mango 10220" & @CRLF & _
"9/93 3 3a x333 pineapple" & @CRLF & _
"9/94 x4 cx.apple 94000" & @CRLF & _
"9/95 5 55 cyz cx.orange"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")