import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+\\/\\d+(?:\\h\\w+)+)\\h(?:\\w+\\.)?([a-zA-Z]+)(?:\\h(\\d+))?$";
final String string = "9/91 a1 2a cx.papaya 94000\n"
+ "9/92 b2 3a x44b mango 10220\n"
+ "9/93 3 3a x333 pineapple\n"
+ "9/94 x4 cx.apple 94000\n"
+ "9/95 5 55 cyz cx.orange";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}