#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d+\.[ \t]*([^-\r\n]+?)(?:$|[ \t]*-[ \t]*(.*))"
Local $sString = "4. Cost/Estimating" & @CRLF & _
"6. Supplier - Minor Material: Specialty" & @CRLF & _
"6. Supplier - Pressure Vessels & Filters" & @CRLF & _
"6. Supplier - Pumps" & @CRLF & _
"6. Supplier - Minor Material: Valves" & @CRLF & _
"6. Supplier - Minor Material: Specialty" & @CRLF & _
"6. Supplier - Other Major Equipment" & @CRLF & _
"7. Manufacturing" & @CRLF & _
"8. Project Management" & @CRLF & _
"9. Order Release (OTR) - Commercial Documents" & @CRLF & _
"9. Order Release (OTR) - Hand-Off" & @CRLF & _
"6. Supplier - Compressors, Drivers & Refrig. Units"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")