import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d+\\.[ \\t]*([^-\\r\\n]+?)(?:$|[ \\t]*-[ \\t]*(.*))";
final String string = "4. Cost/Estimating\n"
+ "6. Supplier - Minor Material: Specialty\n"
+ "6. Supplier - Pressure Vessels & Filters\n"
+ "6. Supplier - Pumps\n"
+ "6. Supplier - Minor Material: Valves\n"
+ "6. Supplier - Minor Material: Specialty\n"
+ "6. Supplier - Other Major Equipment\n"
+ "7. Manufacturing\n"
+ "8. Project Management\n"
+ "9. Order Release (OTR) - Commercial Documents\n"
+ "9. Order Release (OTR) - Hand-Off\n"
+ "6. Supplier - Compressors, Drivers & Refrig. Units";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}