# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\d+\.[ \t]*([^-\r\n]+?)(?:$|[ \t]*-[ \t]*(.*))"
test_str = ("4. Cost/Estimating\n"
"6. Supplier - Minor Material: Specialty\n"
"6. Supplier - Pressure Vessels & Filters\n"
"6. Supplier - Pumps\n"
"6. Supplier - Minor Material: Valves\n"
"6. Supplier - Minor Material: Specialty\n"
"6. Supplier - Other Major Equipment\n"
"7. Manufacturing\n"
"8. Project Management\n"
"9. Order Release (OTR) - Commercial Documents\n"
"9. Order Release (OTR) - Hand-Off\n"
"6. Supplier - Compressors, Drivers & Refrig. Units")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.