re = /<span>([^<]+)<\/[^<]+<a[^>]+>([^<]+)/
str = ' <span>SpanText</span>
<a href="link.html" title="link">Link Text</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end