#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([\u064B-\u0652])"
Local $sString = "بِسْمِ اللَّهِ الرَّحْمَنِ الرَّحِيمِ" & @CRLF & _
"الْحَمْدُ لِلَّهِ رَبِّ الْعَالَمِينَ" & @CRLF & _
"الرَّحْمَنِ الرَّحِيمِ" & @CRLF & _
"مَالِكِ يَوْمِ الدِّينِ" & @CRLF & _
"إِيَّاكَ نَعْبُدُ وَإِيَّاكَ نَسْتَعِينُ" & @CRLF & _
"اهدِنَا الصِّرَاطَ الْمُسْتَقِيمَ" & @CRLF & _
"صِرَاطَ الَّذِينَ أَنْعَمْتَ عَلَيْهِمْ غَيْرِ الْمَغْضُوبِ عَلَيْهِمْ وَلاَ الضَّالِّينَ"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")