import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\u064B-\\u0652])";
final String string = "بِسْمِ اللَّهِ الرَّحْمَنِ الرَّحِيمِ\n"
+ "الْحَمْدُ لِلَّهِ رَبِّ الْعَالَمِينَ\n"
+ "الرَّحْمَنِ الرَّحِيمِ\n"
+ "مَالِكِ يَوْمِ الدِّينِ\n"
+ "إِيَّاكَ نَعْبُدُ وَإِيَّاكَ نَسْتَعِينُ\n"
+ "اهدِنَا الصِّرَاطَ الْمُسْتَقِيمَ\n"
+ "صِرَاطَ الَّذِينَ أَنْعَمْتَ عَلَيْهِمْ غَيْرِ الْمَغْضُوبِ عَلَيْهِمْ وَلاَ الضَّالِّينَ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}