# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([\u064B-\u0652])"
test_str = ("بِسْمِ اللَّهِ الرَّحْمَنِ الرَّحِيمِ\n"
"الْحَمْدُ لِلَّهِ رَبِّ الْعَالَمِينَ\n"
"الرَّحْمَنِ الرَّحِيمِ\n"
"مَالِكِ يَوْمِ الدِّينِ\n"
"إِيَّاكَ نَعْبُدُ وَإِيَّاكَ نَسْتَعِينُ\n"
"اهدِنَا الصِّرَاطَ الْمُسْتَقِيمَ\n"
"صِرَاطَ الَّذِينَ أَنْعَمْتَ عَلَيْهِمْ غَيْرِ الْمَغْضُوبِ عَلَيْهِمْ وَلاَ الضَّالِّينَ")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.