using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^,(]*(?:\([^)(]*\))*[^,)]*";
string input = @"foo,baz(some,otherhjhj ,stuff))))))()( jhjhjhjhjh),hello,goodbye";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}