$re = '/[^,(]*(?:\([^)(]*\))*[^,)]*/';
$str = 'foo,baz(some,otherhjhj ,stuff))))))()( jhjhjhjhjh),hello,goodbye';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);