package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^,(]*(?:\([^)(]*\))*[^,)]*`)
var str = `foo,baz(some,otherhjhj ,stuff))))))()( jhjhjhjhjh),hello,goodbye`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}