#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<_filename_>.*?):(?<line>\d+)(?:[:](?<column>\d+)(?:[:](?<endLine>\d+):(?<endColumn>\d+))?)?: (?<type>\w+): (?<message>.*)\r?(\n|$)"
Local $sString = "# --show-error-end" & @CRLF & _
"src/waybar_check_gmail/config/config.py:19:17:19:17: error: Dict entry 0 has incompatible type "str": "None"; expected "str": "str" [dict-item]" & @CRLF & _
"src/waybar_check_gmail/config/config.py:20:17:20:17: error: Dict entry 1 has incompatible type "str": "None"; expected "str": "str" [dict-item]" & @CRLF & _
"src/waybar_check_gmail/config/config.py:21:17:21:17: error: Dict entry 2 has incompatible type "str": "None"; expected "str": "str" [dict-item]" & @CRLF & _
"src/waybar_check_gmail/config/config.py:26:17:26:17: error: Dict entry 1 has incompatible type "str": "bool"; expected "str": "str" [dict-item]" & @CRLF & _
"src/waybar_check_gmail/config/config.py:27:17:27:17: error: Dict entry 2 has incompatible type "str": "bool"; expected "str": "str" [dict-item]" & @CRLF & _
"src/waybar_check_gmail/config/config.py:28:17:28:17: error: Dict entry 3 has incompatible type "str": "bool"; expected "str": "str" [dict-item]" & @CRLF & _
"src/waybar_check_gmail/config/config.py:29:17:29:17: error: Dict entry 4 has incompatible type "str": "None"; expected "str": "str" [dict-item]" & @CRLF & _
"src/waybar_check_gmail/config/config.py:30:17:30:17: error: Dict entry 5 has incompatible type "str": "bool"; expected "str": "str" [dict-item]" & @CRLF & _
"" & @CRLF & _
"# WITHOUT --show-error-end, ONLY: --show-column-numbers" & @CRLF & _
"[info] src/waybar_check_gmail/config/config.py:19:17: error: Dict entry 0 has incompatible type "str": "None"; expected "str": "str" [dict-item]" & @CRLF & _
"src/waybar_check_gmail/config/config.py:20:17: error: Dict entry 1 has incompatible type "str": "None"; expected "str": "str" [dict-item]" & @CRLF & _
"src/waybar_check_gmail/config/config.py:21:17: error: Dict entry 2 has incompatible type "str": "None"; expected "str": "str" [dict-item]" & @CRLF & _
"src/waybar_check_gmail/config/config.py:26:17: error: Dict entry 1 has incompatible type "str": "bool"; expected "str": "str" [dict-item]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")