use strict;
my $str = '# --show-error-end
src/waybar_check_gmail/config/config.py:19:17:19:17: error: Dict entry 0 has incompatible type "str": "None"; expected "str": "str" [dict-item]
src/waybar_check_gmail/config/config.py:20:17:20:17: error: Dict entry 1 has incompatible type "str": "None"; expected "str": "str" [dict-item]
src/waybar_check_gmail/config/config.py:21:17:21:17: error: Dict entry 2 has incompatible type "str": "None"; expected "str": "str" [dict-item]
src/waybar_check_gmail/config/config.py:26:17:26:17: error: Dict entry 1 has incompatible type "str": "bool"; expected "str": "str" [dict-item]
src/waybar_check_gmail/config/config.py:27:17:27:17: error: Dict entry 2 has incompatible type "str": "bool"; expected "str": "str" [dict-item]
src/waybar_check_gmail/config/config.py:28:17:28:17: error: Dict entry 3 has incompatible type "str": "bool"; expected "str": "str" [dict-item]
src/waybar_check_gmail/config/config.py:29:17:29:17: error: Dict entry 4 has incompatible type "str": "None"; expected "str": "str" [dict-item]
src/waybar_check_gmail/config/config.py:30:17:30:17: error: Dict entry 5 has incompatible type "str": "bool"; expected "str": "str" [dict-item]
# WITHOUT --show-error-end, ONLY: --show-column-numbers
[info] src/waybar_check_gmail/config/config.py:19:17: error: Dict entry 0 has incompatible type "str": "None"; expected "str": "str" [dict-item]
src/waybar_check_gmail/config/config.py:20:17: error: Dict entry 1 has incompatible type "str": "None"; expected "str": "str" [dict-item]
src/waybar_check_gmail/config/config.py:21:17: error: Dict entry 2 has incompatible type "str": "None"; expected "str": "str" [dict-item]
src/waybar_check_gmail/config/config.py:26:17: error: Dict entry 1 has incompatible type "str": "bool"; expected "str": "str" [dict-item]';
my $regex = qr/(?<_filename_>.*?):(?<line>\d+)(?:[:](?<column>\d+)(?:[:](?<endLine>\d+):(?<endColumn>\d+))?)?: (?<type>\w+): (?<message>.*)\r?(\n|$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}