using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<_filename_>.*?):(?<line>\d+)(?:[:](?<column>\d+)(?:[:](?<endLine>\d+):(?<endColumn>\d+))?)?: (?<type>\w+): (?<message>.*)\r?(\n|$)";
string input = @"# --show-error-end
src/waybar_check_gmail/config/config.py:19:17:19:17: error: Dict entry 0 has incompatible type ""str"": ""None""; expected ""str"": ""str"" [dict-item]
src/waybar_check_gmail/config/config.py:20:17:20:17: error: Dict entry 1 has incompatible type ""str"": ""None""; expected ""str"": ""str"" [dict-item]
src/waybar_check_gmail/config/config.py:21:17:21:17: error: Dict entry 2 has incompatible type ""str"": ""None""; expected ""str"": ""str"" [dict-item]
src/waybar_check_gmail/config/config.py:26:17:26:17: error: Dict entry 1 has incompatible type ""str"": ""bool""; expected ""str"": ""str"" [dict-item]
src/waybar_check_gmail/config/config.py:27:17:27:17: error: Dict entry 2 has incompatible type ""str"": ""bool""; expected ""str"": ""str"" [dict-item]
src/waybar_check_gmail/config/config.py:28:17:28:17: error: Dict entry 3 has incompatible type ""str"": ""bool""; expected ""str"": ""str"" [dict-item]
src/waybar_check_gmail/config/config.py:29:17:29:17: error: Dict entry 4 has incompatible type ""str"": ""None""; expected ""str"": ""str"" [dict-item]
src/waybar_check_gmail/config/config.py:30:17:30:17: error: Dict entry 5 has incompatible type ""str"": ""bool""; expected ""str"": ""str"" [dict-item]
# WITHOUT --show-error-end, ONLY: --show-column-numbers
[info] src/waybar_check_gmail/config/config.py:19:17: error: Dict entry 0 has incompatible type ""str"": ""None""; expected ""str"": ""str"" [dict-item]
src/waybar_check_gmail/config/config.py:20:17: error: Dict entry 1 has incompatible type ""str"": ""None""; expected ""str"": ""str"" [dict-item]
src/waybar_check_gmail/config/config.py:21:17: error: Dict entry 2 has incompatible type ""str"": ""None""; expected ""str"": ""str"" [dict-item]
src/waybar_check_gmail/config/config.py:26:17: error: Dict entry 1 has incompatible type ""str"": ""bool""; expected ""str"": ""str"" [dict-item]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}