const regex = /^!?[^\r\n!]*!$(*SKIP)(*FAIL)|!/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^!?[^\\r\\n!]*!$(*SKIP)(*FAIL)|!', 'gm')
const str = `!a! b!
!a! b!
c!
!d!
`;
const subst = `.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);