$re = '/^!?[^\r\n!]*!$(*SKIP)(*FAIL)|!/m';
$str = '!a! b!
!a! b!
c!
!d!
';
$subst = ".";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;