import Foundation
let pattern = #"^!?[^\r\n!]*!$(*SKIP)(*FAIL)|!"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
!a! b!
!a! b!
c!
!d!
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"."#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)