using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<User>(?<=user:)[^]]*)\].*?(?<Serial_Number>(?<=sn:)[^]]*)?\]";
string input = @"<Jul24,11:20:17> TID:6 INFO [user:weblogic] [sn:088039] [dur:806ms] {***message***}>
<Jul24,11:20:17> TID:6 INFO [sn:088039] [dur:806ms] {***message***}> [user:weblogic]
2015-07-27 14:39:23,720 TID:4 ERROR o.p.e.r.a.t.i.o.n.s-102 - [user:weblogic] [dur:1ms] [code:507] Invalid value: Address should be of valid format(xx:xx:)- {*****Message}
2015-07-27 14:39:23,720 TID:6 INFO o.p.e.r.a.t.i.o.n.s-83 - [user:weblogic] [sn:088039] [type:xxx] [dest:xxxxxxxx] [rpc:xxxxxx] [dur:806ms] {*************Message}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}