$re = '/(?<User>(?<=user:)[^]]*)\].*?(?<Serial_Number>(?<=sn:)[^]]*)?\]/m';
$str = '<Jul24,11:20:17> TID:6 INFO [user:weblogic] [sn:088039] [dur:806ms] {***message***}>
<Jul24,11:20:17> TID:6 INFO [sn:088039] [dur:806ms] {***message***}> [user:weblogic]
2015-07-27 14:39:23,720 TID:4 ERROR o.p.e.r.a.t.i.o.n.s-102 - [user:weblogic] [dur:1ms] [code:507] Invalid value: Address should be of valid format(xx:xx:)- {*****Message}
2015-07-27 14:39:23,720 TID:6 INFO o.p.e.r.a.t.i.o.n.s-83 - [user:weblogic] [sn:088039] [type:xxx] [dest:xxxxxxxx] [rpc:xxxxxx] [dur:806ms] {*************Message}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);