# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<User>(?<=user:)[^]]*)\].*?(?<Serial_Number>(?<=sn:)[^]]*)?\]"
test_str = ("<Jul24,11:20:17> TID:6 INFO [user:weblogic] [sn:088039] [dur:806ms] {***message***}>\n"
"<Jul24,11:20:17> TID:6 INFO [sn:088039] [dur:806ms] {***message***}> [user:weblogic] \n"
"2015-07-27 14:39:23,720 TID:4 ERROR o.p.e.r.a.t.i.o.n.s-102 - [user:weblogic] [dur:1ms] [code:507] Invalid value: Address should be of valid format(xx:xx:)- {*****Message} \n"
"2015-07-27 14:39:23,720 TID:6 INFO o.p.e.r.a.t.i.o.n.s-83 - [user:weblogic] [sn:088039] [type:xxx] [dest:xxxxxxxx] [rpc:xxxxxx] [dur:806ms] {*************Message}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.