using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^612\s?[1-5]0\s?0(?:[0-5]\d|6[0-4])\s?0000\s?(?:[0-5]\d|6[0-4])\s?00\s?\d{4}$";
string input = @"61230005000055001234
612 30 005 0000 55 00 1234";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}