const regex = /^612\s?[1-5]0\s?0(?:[0-5]\d|6[0-4])\s?0000\s?(?:[0-5]\d|6[0-4])\s?00\s?\d{4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^612\\s?[1-5]0\\s?0(?:[0-5]\\d|6[0-4])\\s?0000\\s?(?:[0-5]\\d|6[0-4])\\s?00\\s?\\d{4}$', 'gm')
const str = `61230005000055001234
612 30 005 0000 55 00 1234`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}