re = /^612\s?[1-5]0\s?0(?:[0-5]\d|6[0-4])\s?0000\s?(?:[0-5]\d|6[0-4])\s?00\s?\d{4}$/m
str = '61230005000055001234
612 30 005 0000 55 00 1234'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end