import re
regex = re.compile(r"^\s*access-list\s+(\d+)\s*$")
test_str = (" permit tcp 172.16.0.0/12 10.14.0.21/32 eq 80 log\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")