re = /^\s*access-list\s+(\d+)\s*$/
str = ' permit tcp 172.16.0.0/12 10.14.0.21/32 eq 80 log
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end