use strict;
my $str = '<p>V-am povestit eu despre inițiativa Fundației <a href="../../../goo.gl/or6O0O" onclick="__gaTracker(\'send\', \'event\', \'outbound-article\', \'../../../goo.gl/or6O0O\', \'Vodafone\');" title="Vodafone" target="_blank" class="auto-link" rel="nofollow">Vodafone</a> de a sprijini cursurile <a title="primul ajutor" href="../primul-ajutor-tu-poti-salva-viata.html#more-43409">de prim-ajutor</a> organizate de Asociaia React. Acum au trimis un bilanț al campaniei la doar șase luni după lansare: 3.000 de oameni au învățat regulile de bază pentru acordarea primului ajutor în cazul unui astfel de eveniment neplăcut.<span id="more-50085"></span><br />';
my $regex = qr/<a href[\s\S]*?>[\s\S]*?/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}