# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<a href[\s\S]*?>[\s\S]*?"
test_str = "<p>V-am povestit eu despre inițiativa Fundației <a href=\"../../../goo.gl/or6O0O\" onclick=\"__gaTracker('send', 'event', 'outbound-article', '../../../goo.gl/or6O0O', 'Vodafone');\" title=\"Vodafone\" target=\"_blank\" class=\"auto-link\" rel=\"nofollow\">Vodafone</a> de a sprijini cursurile <a title=\"primul ajutor\" href=\"../primul-ajutor-tu-poti-salva-viata.html#more-43409\">de prim-ajutor</a> organizate de Asociaia React. Acum au trimis un bilanț al campaniei la doar șase luni după lansare: 3.000 de oameni au învățat regulile de bază pentru acordarea primului ajutor în cazul unui astfel de eveniment neplăcut.<span id=\"more-50085\"></span><br />"
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.