$re = '/<a href[\s\S]*?>[\s\S]*?/';
$str = '<p>V-am povestit eu despre inițiativa Fundației <a href="../../../goo.gl/or6O0O" onclick="__gaTracker(\'send\', \'event\', \'outbound-article\', \'../../../goo.gl/or6O0O\', \'Vodafone\');" title="Vodafone" target="_blank" class="auto-link" rel="nofollow">Vodafone</a> de a sprijini cursurile <a title="primul ajutor" href="../primul-ajutor-tu-poti-salva-viata.html#more-43409">de prim-ajutor</a> organizate de Asociaia React. Acum au trimis un bilanț al campaniei la doar șase luni după lansare: 3.000 de oameni au învățat regulile de bază pentru acordarea primului ajutor în cazul unui astfel de eveniment neplăcut.<span id="more-50085"></span><br />';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);