#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)PI\/(?!master).*"
Local $sString = "testfolder/PI/something" & @CRLF & _
"testfolder/PI/anotherthing2" & @CRLF & _
"testfolder/PI/master" & @CRLF & _
"testfolder/PI/whatever" & @CRLF & _
"otherfolder/something_else"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")