using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"PI\/(?!master).*";
string input = @"testfolder/PI/something
testfolder/PI/anotherthing2
testfolder/PI/master
testfolder/PI/whatever
otherfolder/something_else";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}