#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https?://(?:\w+(?:-\w+)*\.)*(?!domain-name\.com)[\w-]+\.[\w-]+(?=$|[/?#])"
Local $sString = "https://subdomain.domain-name.com" & @CRLF & _
"http://subdomain.domain-name.com" & @CRLF & _
"https://domain-name.com" & @CRLF & _
"https://subdomain.domain-name.com/some-url" & @CRLF & _
"https://domain-name.com/some-url" & @CRLF & _
"https://sub-subdomain.subdomain.domain-name.com" & @CRLF & _
"https://domain-name.com?params=values" & @CRLF & _
"https://domain-name.com#fragment" & @CRLF & _
"" & @CRLF & _
"https://subdomain.not-domain-name.com" & @CRLF & _
"https://not-domain-name.com" & @CRLF & _
"https://not-domain-name.com/some-url" & @CRLF & _
"https://not-domain-name.com?params=values" & @CRLF & _
"https://not-domain-name.com#fragment" & @CRLF & _
"http://subdomain.not-domain-name.com/some-url" & @CRLF & _
"" & @CRLF & _
"../local.links"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")