use strict;
my $str = 'https://subdomain.domain-name.com
http://subdomain.domain-name.com
https://domain-name.com
https://subdomain.domain-name.com/some-url
https://domain-name.com/some-url
https://sub-subdomain.subdomain.domain-name.com
https://domain-name.com?params=values
https://domain-name.com#fragment
https://subdomain.not-domain-name.com
https://not-domain-name.com
https://not-domain-name.com/some-url
https://not-domain-name.com?params=values
https://not-domain-name.com#fragment
http://subdomain.not-domain-name.com/some-url
../local.links';
my $regex = qr@^https?://(?:\w+(?:-\w+)*\.)*(?!domain-name\.com)[\w-]+\.[\w-]+(?=$|[/?#])@mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}