# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^https?://(?:\w+(?:-\w+)*\.)*(?!domain-name\.com)[\w-]+\.[\w-]+(?=$|[/?#])"
test_str = ("https://subdomain.domain-name.com\n"
"http://subdomain.domain-name.com\n"
"https://domain-name.com\n"
"https://subdomain.domain-name.com/some-url\n"
"https://domain-name.com/some-url\n"
"https://sub-subdomain.subdomain.domain-name.com\n"
"https://domain-name.com?params=values\n"
"https://domain-name.com#fragment\n\n"
"https://subdomain.not-domain-name.com\n"
"https://not-domain-name.com\n"
"https://not-domain-name.com/some-url\n"
"https://not-domain-name.com?params=values\n"
"https://not-domain-name.com#fragment\n"
"http://subdomain.not-domain-name.com/some-url\n\n"
"../local.links")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.