using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?P<Timecode>(?P<Hours>[0-1][0-9]|2[0-3]):(?P<Minutes>[0-5][0-9]):(?P<Seconds>[0-5][0-9]):(?P<Frames>[0-1][0-9]|2[0-4]))$";
string input = @"23:59:59:24
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}