import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<Timecode>(?P<Hours>[0-1][0-9]|2[0-3]):(?P<Minutes>[0-5][0-9]):(?P<Seconds>[0-5][0-9]):(?P<Frames>[0-1][0-9]|2[0-4]))$";
final String string = "23:59:59:24\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}