#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d{2} \S+ \d{4}$|\S+ \d{2} \d{4}$|\d{2}\-\S+\d{4}$|\d{4} \S+ \d{2}$"
Local $sString = "APP was removed from A/C DHC-8-201 on July 10 2019" & @CRLF & _
"APP was removed from A/C HHC-9-200 on December 11 2002" & @CRLF & _
"APP was removed from A/C CHC-5-101 on June 15 2020" & @CRLF & _
"APP was removed from A/C CHC-5-101 on 20 June 2020" & @CRLF & _
"APP was removed from A/C CHC-5-101 on 20-June-2020" & @CRLF & _
"APP was removed from A/C DHC-8-201 on 2020 April 25"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")