import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{2} \\S+ \\d{4}$|\\S+ \\d{2} \\d{4}$|\\d{2}\\-\\S+\\d{4}$|\\d{4} \\S+ \\d{2}$";
final String string = "APP was removed from A/C DHC-8-201 on July 10 2019\n"
+ "APP was removed from A/C HHC-9-200 on December 11 2002\n"
+ "APP was removed from A/C CHC-5-101 on June 15 2020\n"
+ "APP was removed from A/C CHC-5-101 on 20 June 2020\n"
+ "APP was removed from A/C CHC-5-101 on 20-June-2020\n"
+ "APP was removed from A/C DHC-8-201 on 2020 April 25";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}