$re = '/\d{2} \S+ \d{4}$|\S+ \d{2} \d{4}$|\d{2}\-\S+\d{4}$|\d{4} \S+ \d{2}$/m';
$str = 'APP was removed from A/C DHC-8-201 on July 10 2019
APP was removed from A/C HHC-9-200 on December 11 2002
APP was removed from A/C CHC-5-101 on June 15 2020
APP was removed from A/C CHC-5-101 on 20 June 2020
APP was removed from A/C CHC-5-101 on 20-June-2020
APP was removed from A/C DHC-8-201 on 2020 April 25';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);