#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*(?:me#BADTAG|me#XmlTools)).*"
Local $sString = "08-06 15:46:13.883 27841-12352/tv.me.sdkapptest D/me#BADTAG﹕ process" & @CRLF & _
"08-06 15:46:13.883 27841-12352/tv.me.sdkapptest D/me#BADTAG﹕ processUri" & @CRLF & _
"08-06 15:46:13.884 27841-12352/tv.me.sdkapptest D/me#BADTAG﹕ About to create doc from InputStream" & @CRLF & _
"08-06 15:46:13.886 27841-12352/tv.me.sdkapptest D/me#BADTAG﹕ Doc successfully created." & @CRLF & _
"08-06 15:46:13.887 27841-12352/tv.me.sdkapptest D/me#BADTAG﹕ About to merge doc into main doc." & @CRLF & _
"08-06 15:46:13.887 27841-12352/tv.me.sdkapptest D/me#XmlTools﹕ xmlDocumentToString" & @CRLF & _
"08-06 15:46:13.895 27841-12352/tv.me.sdkapptest D/me#BADTAG﹕ Merge successful." & @CRLF & _
"08-06 15:46:13.895 27841-12352/tv.me.sdkapptest D/me#BADTAG﹕ Doc is a wrapper." & @CRLF & _
"08-06 15:46:13.905 27841-12352/tv.me.sdkapptest D/me#BADTAG﹕ processUri" & @CRLF & _
"08-06 15:46:13.905 27841-12352/not.to.me D/me#BADTAG﹕ begin" & @CRLF & _
"08-06 15:46:13.905 27841-12352/tv.me.sdkapptest D/me#MainActivity : so" & @CRLF & _
"08-06 16:00:01.037 940-977/? I/ProcessStatsService﹕ Prepared write state in 0ms"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")