$re = '/^(?!.*(?:me#BADTAG|me#XmlTools)).*/m';
$str = '08-06 15:46:13.883 27841-12352/tv.me.sdkapptest D/me#BADTAG﹕ process
08-06 15:46:13.883 27841-12352/tv.me.sdkapptest D/me#BADTAG﹕ processUri
08-06 15:46:13.884 27841-12352/tv.me.sdkapptest D/me#BADTAG﹕ About to create doc from InputStream
08-06 15:46:13.886 27841-12352/tv.me.sdkapptest D/me#BADTAG﹕ Doc successfully created.
08-06 15:46:13.887 27841-12352/tv.me.sdkapptest D/me#BADTAG﹕ About to merge doc into main doc.
08-06 15:46:13.887 27841-12352/tv.me.sdkapptest D/me#XmlTools﹕ xmlDocumentToString
08-06 15:46:13.895 27841-12352/tv.me.sdkapptest D/me#BADTAG﹕ Merge successful.
08-06 15:46:13.895 27841-12352/tv.me.sdkapptest D/me#BADTAG﹕ Doc is a wrapper.
08-06 15:46:13.905 27841-12352/tv.me.sdkapptest D/me#BADTAG﹕ processUri
08-06 15:46:13.905 27841-12352/not.to.me D/me#BADTAG﹕ begin
08-06 15:46:13.905 27841-12352/tv.me.sdkapptest D/me#MainActivity : so
08-06 16:00:01.037 940-977/? I/ProcessStatsService﹕ Prepared write state in 0ms';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);