import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*(?:me#BADTAG|me#XmlTools)).*";
final String string = "08-06 15:46:13.883 27841-12352/tv.me.sdkapptest D/me#BADTAG﹕ process\n"
+ "08-06 15:46:13.883 27841-12352/tv.me.sdkapptest D/me#BADTAG﹕ processUri\n"
+ "08-06 15:46:13.884 27841-12352/tv.me.sdkapptest D/me#BADTAG﹕ About to create doc from InputStream\n"
+ "08-06 15:46:13.886 27841-12352/tv.me.sdkapptest D/me#BADTAG﹕ Doc successfully created.\n"
+ "08-06 15:46:13.887 27841-12352/tv.me.sdkapptest D/me#BADTAG﹕ About to merge doc into main doc.\n"
+ "08-06 15:46:13.887 27841-12352/tv.me.sdkapptest D/me#XmlTools﹕ xmlDocumentToString\n"
+ "08-06 15:46:13.895 27841-12352/tv.me.sdkapptest D/me#BADTAG﹕ Merge successful.\n"
+ "08-06 15:46:13.895 27841-12352/tv.me.sdkapptest D/me#BADTAG﹕ Doc is a wrapper.\n"
+ "08-06 15:46:13.905 27841-12352/tv.me.sdkapptest D/me#BADTAG﹕ processUri\n"
+ "08-06 15:46:13.905 27841-12352/not.to.me D/me#BADTAG﹕ begin\n"
+ "08-06 15:46:13.905 27841-12352/tv.me.sdkapptest D/me#MainActivity : so\n"
+ "08-06 16:00:01.037 940-977/? I/ProcessStatsService﹕ Prepared write state in 0ms";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}