#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)customfield_11301(.*?)customfield_10730"
Local $sString = " "customfield_11300": null," & @CRLF & _
" "customfield_11301": [" & @CRLF & _
" {" & @CRLF & _
" "self": "xxxxxxxx"," & @CRLF & _
" "value": "xxxxxxxxx"," & @CRLF & _
" "id": "10467"" & @CRLF & _
" }" & @CRLF & _
" ]," & @CRLF & _
" "customfield_10730": null," & @CRLF & _
" "customfield_11302": null," & @CRLF & _
" "customfield_10720": 0.0," & @CRLF & _
" "customfield_11300": null," & @CRLF & _
" "customfield_11301": [" & @CRLF & _
" {" & @CRLF & _
" "self": "zzzzzzzzzzzzz"," & @CRLF & _
" "value": "zzzzzzzzzzz"," & @CRLF & _
" "id": "10467"" & @CRLF & _
" }" & @CRLF & _
" ]," & @CRLF & _
" "customfield_10730": null," & @CRLF & _
" "customfield_11302": null," & @CRLF & _
" "customfield_10720": 0.0,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")