package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)customfield_11301(.*?)customfield_10730`)
var str = ` "customfield_11300": null,
"customfield_11301": [
{
"self": "xxxxxxxx",
"value": "xxxxxxxxx",
"id": "10467"
}
],
"customfield_10730": null,
"customfield_11302": null,
"customfield_10720": 0.0,
"customfield_11300": null,
"customfield_11301": [
{
"self": "zzzzzzzzzzzzz",
"value": "zzzzzzzzzzz",
"id": "10467"
}
],
"customfield_10730": null,
"customfield_11302": null,
"customfield_10720": 0.0,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}