use strict;
my $str = 'a12Ads';
my $regex = qr/(?=.*[A-Z])(?=.*[a-z]).*/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";