import re
regex = re.compile(r"(?=.*[A-Z])(?=.*[a-z]).*")
test_str = "a12Ads"
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)