import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\/dp\\/).*?(?=\\/)";
final String string = "http://www.amazon.fr/Les-cahiers-d%C3%A9criture-n%C2%BA1-Apprentissage/dp/221895608X/ref=zg_bs_3967461_1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}