const regex = /(?<=\/dp\/).*?(?=\/)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\\/dp\\\/).*?(?=\\\/)', '')
const str = `http://www.amazon.fr/Les-cahiers-d%C3%A9criture-n%C2%BA1-Apprentissage/dp/221895608X/ref=zg_bs_3967461_1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}